Помогите,пожалуйста, написать программу по теме "Ветвление в алгоритмах" для Pascal.
Задача: определить существует ли треугольник со сторонами ABC и, если существует, то какой он (равнобедренный, равносторонний, произвольный).
Заранее большое спасибо!
Copyright © 2024 SCHOLAR.TIPS - All rights reserved.
Answers & Comments
(*Pascal ABC.Net*)
program triangle;
var a,b,c: integer;
begin
write('Введите стороны:'); readln(a,b,c);
if (a=b) and (a=c) then
write('Треугольник равносторонний')
else if (a=b) or (b=c) or (a=c) then write('Треугольник равнобедренный')
else write('Треугольник произвольный');
end.