Пожалуйста помогите, используя оператор выбора, составьте программу, которая по введенному номеру месяца будет выводить название соответствующего времени года (зима, весна, лето, осень)
St1nless
program nomermesaca; var a:integer; begin writeln('введите номер месяца'); readln(a); Case x of 1,2,12:writeln (‘зима’); 3,4,5:writeln (‘весна’); 6,7,8:writeln (‘лето’); 9,10,11:writeln (‘осень’) else writeln (‘ошибка’); readln; end.
St1nless
нет не так program nomermesaca; var x:byte; begin writeln(‘ введите номер месяца ‘); readln(x); Case x of 1,2,12:writeln (‘зима’); 3,4,5:writeln (‘весна’); 6,7,8:writeln (‘лето’); 9,10,11:writeln ('осень’) else writeln ('ошибка'); end; readln; end.
St1nless
вот так вот , сорь что первые разы не правильно скинул program nomermesaca; var a:integer; begin writeln('введите номер месяца'); readln(a); Case a of 1,2,12:writeln ('зима'); 3,4,5:writeln ('весна'); 6,7,8:writeln ('лето'); 9,10,11:writeln ('осень') else writeln ('ошибка'); end; readln; end.
Answers & Comments
Verified answer
Удачи)))))))))))))))))var a:integer;
begin
writeln('введите номер месяца'); readln(a); Case x of
1,2,12:writeln (‘зима’);
3,4,5:writeln (‘весна’);
6,7,8:writeln (‘лето’);
9,10,11:writeln (‘осень’)
else
writeln (‘ошибка’);
readln;
end.
program nomermesaca;
var x:byte;
begin
writeln(‘ введите номер месяца ‘); readln(x); Case x of
1,2,12:writeln (‘зима’);
3,4,5:writeln (‘весна’);
6,7,8:writeln (‘лето’);
9,10,11:writeln ('осень’)
else
writeln ('ошибка');
end;
readln;
end.
program nomermesaca;
var a:integer;
begin
writeln('введите номер месяца'); readln(a);
Case a of
1,2,12:writeln ('зима');
3,4,5:writeln ('весна');
6,7,8:writeln ('лето');
9,10,11:writeln ('осень')
else
writeln ('ошибка');
end;
readln;
end.