Пожалуйста помогите решить задачу по ИКТ. СРОЧНО!!! 39. Составьте программу вычисления длины боковой стороны равнобедренного треугольника, у которого площадь равна S, а длина основания в три раза больше длины высоты, опущенной на него.
Площадь треугольника - s = a*h/2 a = 3*h ⇒ s = 3*h*h/2 ⇒ h = √(2*s/3) Искомая боковая сторона треугольника - это гипотенуза треугольника со сторонами a/2 (=3*h/2) и h ⇒ b^2 = (3*h/2)^2+h^2
var s,b,h:real; begin readln(s); h:=sqrt(2*s/3); //s:=3*h*h/2 b:=sqrt(13)*h/2; // b^2 =(3*h/2)^2+h^2 writeln('a = ',3*h:5:2,' h = ',h:5:2); writeln('b = ',b:5:2); end.
Пример: 16 a = 9.80 h = 3.27 b = 5.89
2 votes Thanks 1
Ben5rokz
А можно пожалуйста ещё решение, только не программой, а задачей
pankuznetsov
На PascalABC. (20 символов аиыоалокуаикуцлокиуцоауц)
Answers & Comments
Verified answer
Площадь треугольника - s = a*h/2a = 3*h ⇒ s = 3*h*h/2 ⇒ h = √(2*s/3)
Искомая боковая сторона треугольника - это гипотенуза треугольника со сторонами a/2 (=3*h/2) и h ⇒ b^2 = (3*h/2)^2+h^2
var s,b,h:real;
begin
readln(s);
h:=sqrt(2*s/3); //s:=3*h*h/2
b:=sqrt(13)*h/2; // b^2 =(3*h/2)^2+h^2
writeln('a = ',3*h:5:2,' h = ',h:5:2);
writeln('b = ',b:5:2);
end.
Пример:
16
a = 9.80 h = 3.27
b = 5.89
(20 символов аиыоалокуаикуцлокиуцоауц)