Home
О нас
Products
Services
Регистрация
Войти
Поиск
Лессикаа
@Лессикаа
August 2022
2
18
Report
Пожалуйста, помогите решить задачу по информатике через PascalABC.
Дана строка, содержащая дефис (например: город-герой). Поменяйте 2 слова между собой,
чтобы получилось наоборот (герой-город).
Заранее спасибо.
Please enter comments
Please enter your name.
Please enter the correct email address.
Agree to
terms of service
You must agree before submitting.
Send
Answers & Comments
petyaGavrikov
Verified answer
Var s:string; l,p:integer;
begin
readln(s);
l:=length(s);
p:=pos('-',s);
s:=copy(s,p+1,l-p)+'-'+copy(s,1,p-1);
writeln(s);
end.
Пример:
город-герой
герой-город
1 votes
Thanks 1
Лессикаа
Спасибо вам огромное!
petyaGavrikov
Пожалуйста.
Giammy
PascalABC.NET
Версия 3.3. сборка 1583 (25.11.2017)
var s,s1,s2: string;
begin
write('s='); readln(s);
s1:=copy(s,1,pos('-',s)-1);
s2:=copy(s,pos('-',s)+1,length(s)-pos('-',s));
write('s=',s2+'-'+s1);
end.
0 votes
Thanks 0
More Questions From This User
See All
Лессикаа
August 2022 | 0 Ответы
Слова в тексте разделены пробелом. Напишите программу, выводящая количество симв...
Answer
Лессикаа
July 2022 | 0 Ответы
Функция торможения заключаются в том, что: а) задерживает распространение возбуж...
Answer
рекомендуемые вопросы
rarrrrrrrr
August 2022 | 0 Ответы
о чем должны позаботиться в первую очередь взрослые при организационном вывозе н...
danilarsentev
August 2022 | 0 Ответы
Есть два станка на которых выпускают одинаковые запчасти один производит a запча...
myachina8
August 2022 | 0 Ответы
Найти по графику отношение V3:V1. В ответах написано 9, но нужно решение...
ydpmn7cn6w
August 2022 | 0 Ответы
Choose the correct preposition: 1.I am fond (out,of,from) literature. 2.where ar...
millermilena658
August 2022 | 0 Ответы
Определите Как создавалась и кто создавал арабское государство в крации...
MrZooM222
August 2022 | 0 Ответы
Ч. Айтманов в рассказе "Красное яблоко" использует метод рассказ в рассказе. Опи...
timobila47
August 2022 | 0 Ответы
каково было назначение каждой из частей византийского храма? помогите пожалуйста...
ivanyyaremkiv
August 2022 | 0 Ответы
moment. 6....
Участник Знаний
August 2022 | 0 Ответы
Пожалуйста!!!!!!!!!!!!...
sarvinozwakirjanova
August 2022 | 0 Ответы
помогите пожалусто пж...
×
Report "Пожалуйста, помогите решить задачу по информатике через PascalABC. Дана строка, ..."
Your name
Email
Reason
-Select Reason-
Pornographic
Defamatory
Illegal/Unlawful
Spam
Other Terms Of Service Violation
File a copyright complaint
Description
Helpful Links
О нас
Политика конфиденциальности
Правила и условия
Copyright
Контакты
Helpful Social
Get monthly updates
Submit
Copyright © 2025 SCHOLAR.TIPS - All rights reserved.
Answers & Comments
Verified answer
Var s:string; l,p:integer;begin
readln(s);
l:=length(s);
p:=pos('-',s);
s:=copy(s,p+1,l-p)+'-'+copy(s,1,p-1);
writeln(s);
end.
Пример:
город-герой
герой-город
Версия 3.3. сборка 1583 (25.11.2017)
var s,s1,s2: string;
begin
write('s='); readln(s);
s1:=copy(s,1,pos('-',s)-1);
s2:=copy(s,pos('-',s)+1,length(s)-pos('-',s));
write('s=',s2+'-'+s1);
end.