Пожалуйста помогите с информатикой!!!
За ответ 27 баллов
1.1. Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое двузначных чисел или сообщает, что таких чисел нет. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Программа должна вывести среднее арифметическое двузначных чисел или вывести NO, если таких чисел в последовательности нет.
Пример работы программы:
входные данные: 13, 154, 56, 0 выходные данные: 34,5
Answers & Comments
Объяснение:
Пишу на С++.
#include <iostream>
using namespace std;
int main()
{
int a=1,s=0,k=0;
while (a!=0)
{
cin>>a;
if ((a!=0)&&(a/100==0)&&(a%100>=10))
{
k++;
s=s+a;
}
}
if (k!=0) cout<<(s/k).;
else cout<<"NO";
return 0;
}