ПОЖАЛУЙСТА ПОМОГИТЕ, УМОЛЯЮ ОЧЕНЬ СРОЧНО, ПОЖАЛУЙСТА
Составьте программы на Паскале для решения задач:
1. Напишите на АЯ алгоритм сложения двух простых дробей ( без сокращения дроби)
2. Напишите на АЯ алгоритм вычисления y по формуле y=(1-x^2+5x^4)^2 , где x - заданное целое число
3. Напишите наиболее короткие алгоритмы вычисления выражения y=x^10
ПОМОГИТЕ ПОЖАЛУЙСТА
Answers & Comments
Ответ:
Задание 1)
Program Task_1;
var
a, b, c, d: integer;
begin
writeln('Напишите значение числителя первой дроби:');
readln(a);
writeln('Напишите значение знаменателя первой дроби:');
readln(b);
writeln('Напишите значение числителя второй дроби:');
readln(c);
writeln('Напишите значение знаменателя второй дроби:');
readln(d);
writeln('Сложение двух данных дробей равно: ', (a/b)+(c/d));
end.
Задание 2)
Program Task_2;
var
x,y: integer;
begin
writeln('Введите значение переменной x:');
readln(x);
writeln('y=(1-x^2+5x^4)^2, y = ', sqr(1-x*x+5*sqr(x*x)));
end.
Задание 3)
Program Task_3;
var
x,y: real;
begin
writeln('Введите значение переменной x:');
readln(x);
y:= x*x*x*x*x*x*x*x*x*x;
writeln('1 способ: y = ', y);
y:= exp(ln(x)*10);
writeln('2 способ: y = ', y);
end.