Пожалуйста,помогите решитьn задачи Pascal.Помогите решить хотя бы те ,которые сможете♥♥.СРОЧНО НУЖНО НА ЗАВТРА.
1)Заполните массив их 20 элементов целыми числами из интервала [-10;19],используя генератор случайных величин.
2)Заполнить массив из 10 элементов целыми числами из интервала -20-29 числа вводятся с клавиатуры.
3)Используя программу к задаче 1,напишите программу,которая подсчитывает количество положительных элементов массива.
4)Используя программу к задаче 1,напишите программу ,которая заменяет все отрицательные элементы массива на 0.
5)Используя программу к задаче 1,напишите программу,которая находит сумму всех положительных элементов массива.
Answers & Comments
var a:array [1..20] of integer;
i:integer;
begin
randomize;
for i:=1 to 20 do begin
a[i]:=random(19-(-10)+1)+-10;
write (a[i],' ');
end;
end.
Задача №2
var a:array [1..20] of integer;
i:integer;
begin
writeln('Введите числа в интервале [-20;29]');
for i:=1 to 10 do read(a[i]);
for i:=1 to 10 do
if (a[i]>-29) and (a[i]<20) then write(a[i],' ');
end.
Задача №3
var a:array [1..20] of integer;
i,sum:integer;
begin
randomize;
sum:=0;
for i:=1 to 20 do
begin
a[i]:=random(19-(-10)+1)+-10;
write (a[i],' ');
if a[i]>0 then sum:=sum+1;
end;
writeln('Количество положительных элементов массива = ', sum);
end.
Задача №4
var a:array [1..20] of integer;
i:integer;
begin
randomize;
for i:=1 to 20 do
begin
a[i]:=random(19-(-10)+1)+-10;
if a[i]<0 then a[i]:=0;
write (a[i],' ');
end;
end.
Задача №5
var a:array [1..20] of integer;
i,sum:integer;
begin
randomize;
sum:=0;
for i:=1 to 20 do
begin
a[i]:=random(19-(-10)+1)+-10;
write (a[i],' ');
if a[i]>0 then sum:=sum+a[i];
end;
writeln('Сумма положительных элементов массива = ', sum);
end.