Программа на с++
Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов.
Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .
Выходные данные
Программа должна вывести в одной строке минимальный и максимальный из чётных положительных элементов массива, разделив их пробелом. Если в массиве нет чётных положительных элементов, программа должна вывести два числа -1.
Примеры
входные данные
6
-2 -1 2 3 5 6
выходные данные
2 6
Answers & Comments
using namespace std;
int main() {
int n;
cin >> n;
int *arr = new int[n];
for (int i = 0; i < n; i++) {
cin >> arr[i];
}
int max = -1;
int min = -1;
for (int i = 1; i < n; i++) {
if (arr[i] > 0 && arr[i] % 2 == 0) {
if (min == -1) {
min = arr[i];
}
if (max < arr[i]) {
max = arr[i];
}
if (min > arr[i]) {
min = arr[i];
}
}
}
cout << min << " " << max;
system("pause");
return 0;}