Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести среднее арифметичесткое чисел, трёхзначных, или вывести "NO", если таких чисел нет. Значение выводить с точностью до сотых.
Answers & Comments
var
s, k : integer;
begin
var n := ReadlnInteger('Сколько будет чисел? ');
writeln('Вводите числа');
var a := ReadArrInteger(n);
for var i:=0 to n-1 do
if (a[i] > 99) and
(a[i] < 1000) then begin
s := s + a[i];
k += 1
end;
if k = 0 then
writeln('NO')
else
writeln('Среднее арифметическое равно ', (s / k):8:2)
end.