Программа в паскале, помогите пожалуйста. Даны два действительных числа. Составьте программу, которая меньшее из них заменяет их полусуммой, а большее - их произведением.
Answers & Comments
furs1975
Program gg; var x,y,c:real; begin read(x,y); if x>y then begin c:=y; y:=(x+y)/2; x:=x*c; end else begin c:=x; x:=(x+y)/2; y:=y*c; end; write('x=',x,'y=',y) end.
Answers & Comments
var x,y,c:real;
begin
read(x,y);
if x>y then
begin
c:=y;
y:=(x+y)/2;
x:=x*c;
end
else
begin
c:=x;
x:=(x+y)/2;
y:=y*c;
end;
write('x=',x,'y=',y)
end.