программирование на C++. Помогите решить задачу пж!!!
Напишите программу, которая в последовательности целых чисел определяет среднее арифметическое нечетных чисел. Программа получает на вход целые положительные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введенные числа не превышают 10 000.
Программа должна вывести одно число: среднее арифметическое нечетных чисел (с точностью до десятых)
Пример работы программы
Входные данные
7
2
7
0
Выходные данные
7.0
Answers & Comments
#include <iostream>
#include <stdio.h>
using namespace std;
int main()
{
int sum=0,n,count=1, count_ch=0;
float result;
cin >> n;
if (n<10000)
{
while (n != 0)
{
if (n % 2 == 0)
{
sum += n;
count_ch++;
}
cin >> n;
count++;
if (n > 10000 or count > 1000)
{
break;
}
}
}
result = sum/count_ch;
printf("%.2f",result);
}