ПРОШУ ПОМОЧЬ! ДАМ 100 БАЛЛОВ Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y – действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы. Программист торопился и написал программу неправильно. Вот она: var x, y: real; begin readln(x, y); if y <= x then if y >= -x then if x*x+y*y <= 1 then write('принадлежит') else write('не принадлежит'); end.Последовательно выполните следующее: 1)Приведите пример таких чисел x, y, при которых программа неверно решает поставленную задачу. 2)2) Укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы. (Это можно сделать несколькими способами, поэтому можно указать любой способ доработки исходной программы).
Please enter comments
Please enter your name.
Please enter the correct email address.
You must agree before submitting.

Copyright © 2025 SCHOLAR.TIPS - All rights reserved.