Разработать модель задачи, составить алгоритм и написать программу для вычисления площади и гипотенузы равнобедренного прямоугольного треугольника, если известен его катет. Помогите, пожалуйста
Модель: Пусть a - катет треугольника, тогда его площадь S=1/2 *a *a гипотенуза c = √(a²+a²) Программа: var a,s,c:real; begin write('a='); readln(a); s:=a*a/2; c:=sqrt(2*a*a); writeln('s=',s,' c=',c); end.
Answers & Comments
Verified answer
Модель:Пусть a - катет треугольника,
тогда его площадь S=1/2 *a *a
гипотенуза c = √(a²+a²)
Программа:
var a,s,c:real;
begin
write('a='); readln(a);
s:=a*a/2;
c:=sqrt(2*a*a);
writeln('s=',s,' c=',c);
end.
Пример:
a=4
s=8 c=5.66