Home
О нас
Products
Services
Регистрация
Войти
Поиск
kosimsher
@kosimsher
July 2022
1
6
Report
ребята плиз мне очень нужно ответь
Составить программу, которая бы запрашивала Хнач , Хкон , шаг C и определяла сумму всех отрицательных чисел от Хнач до Хкон с шагом С (решить задачу, используя цикл с постусло-вием – repeat … until).
Please enter comments
Please enter your name.
Please enter the correct email address.
Agree to
terms of service
You must agree before submitting.
Send
Answers & Comments
Gleb1Kosyrev
Verified answer
//Pascal ABC.NET 3.1 сборка 1256
Var
n,k,c,s,kar:real;
i:integer;
begin
read(n,k,c);
i:=0;
s:=0;
kar:=n;
repeat
if n<0 then s:=s+n;
inc(i);
n:=kar+i*c;
until n>k;
writeln(s);
end.
Пример ввода:
-3
1
1.1
Пример вывода:
-5.7
0 votes
Thanks 0
kosimsher
можеш создать схему этого где начала ввод и канец
Gleb1Kosyrev
Я так понимаю, Вы имеете в виду блок-схему. Закончу с одной задачей и сделаю.
kosimsher
ок спасибо
kosimsher
спасибо
More Questions From This User
See All
kosimsher
July 2022 | 0 Ответы
Составить программу, выполняющую следующие действия: Вводит с клавиатуры строку ...
Answer
kosimsher
July 2022 | 0 Ответы
Плиз помогите мне нужно ответь Определить дату и день недели, которые наступят ...
Answer
рекомендуемые вопросы
rarrrrrrrr
August 2022 | 0 Ответы
о чем должны позаботиться в первую очередь взрослые при организационном вывозе н...
danilarsentev
August 2022 | 0 Ответы
Есть два станка на которых выпускают одинаковые запчасти один производит a запча...
myachina8
August 2022 | 0 Ответы
Найти по графику отношение V3:V1. В ответах написано 9, но нужно решение...
ydpmn7cn6w
August 2022 | 0 Ответы
Choose the correct preposition: 1.I am fond (out,of,from) literature. 2.where ar...
millermilena658
August 2022 | 0 Ответы
Определите Как создавалась и кто создавал арабское государство в крации...
MrZooM222
August 2022 | 0 Ответы
Ч. Айтманов в рассказе "Красное яблоко" использует метод рассказ в рассказе. Опи...
timobila47
August 2022 | 0 Ответы
каково было назначение каждой из частей византийского храма? помогите пожалуйста...
ivanyyaremkiv
August 2022 | 0 Ответы
moment. 6....
Участник Знаний
August 2022 | 0 Ответы
Пожалуйста!!!!!!!!!!!!...
sarvinozwakirjanova
August 2022 | 0 Ответы
помогите пожалусто пж...
×
Report "ребята плиз мне очень нужно ответь Составить программу, которая бы запрашивала ..."
Your name
Email
Reason
-Select Reason-
Pornographic
Defamatory
Illegal/Unlawful
Spam
Other Terms Of Service Violation
File a copyright complaint
Description
Helpful Links
О нас
Политика конфиденциальности
Правила и условия
Copyright
Контакты
Helpful Social
Get monthly updates
Submit
Copyright © 2025 SCHOLAR.TIPS - All rights reserved.
Answers & Comments
Verified answer
//Pascal ABC.NET 3.1 сборка 1256Var
n,k,c,s,kar:real;
i:integer;
begin
read(n,k,c);
i:=0;
s:=0;
kar:=n;
repeat
if n<0 then s:=s+n;
inc(i);
n:=kar+i*c;
until n>k;
writeln(s);
end.
Пример ввода:
-3
1
1.1
Пример вывода:
-5.7