С++ используя switch
Написать программу, которая по номеру месяца N выводит количество дней в нем. входные данные Программа считывает с клавиатуры натуральное число N (1 <= N <= 12).
Исходные данные Программа выводит на экран одно натуральное число - количество дней в заданном месяце.
Примеры входных и выходных данных Введение: 2 Вывод: 28
Введение 12 Вывод:31
Введение 4 Вывод: 30
Answers & Comments
#include <iostream>
using namespace std;
void get_days(int n){
switch(n)
{
case 1:
cout << 31;
case 2:
cout << 28;
case 3:
cout << 31;
case 4:
cout << 30;
case 5:
cout << 31;
case 6:
cout << 30;
case 7:
cout << 31;
case 8:
cout << 31;
case 9:
cout << 30;
case 10:
cout << 31;
case 11:
cout << 30;
case 12:
cout << 31;
}
}
int main() {
int n;
cin >> n;
if(1 <= n <= 12)
{
get_days(n);
}
return 0;
}