Составить линейную программу, печатающую значение true, если указанное высказывание является истинным, и false
— в противном случае.
Цифры данного трехзначного числа N являются членами арифметической прогрессии.
2 Составить программу с ветвлением, печатающее слово ‘ДА’, если указанное высказывание является истинным, и
‘НЕТ’ — в противном случае. Язык с++. Надо с обьяснениями
Answers & Comments
#include <iostream>
#include <cstdlib>
using namespace std;
int main()
{
int number; //Вводимое число
int difference_first, difference_second; //переменные проверки арифм. прогр.
cout << "Enter three digit number: "; cin >> number; //ввод трехзначного числа
while(number < 100 or number >= 1000){
//проверка числа на трехзначность
cout << "Error!\nEnter three digit number: "; cin >> number;
}
difference_first = number % 10 - (number / 10 % 10); //разница между третьей цифрой и второй
difference_second = (number / 10 % 10) - (number / 100 % 10); // разница между второй цифрой и первой
if(difference_first == difference_second){ // если эти разницы равны, значит
cout << "YES!" << endl; // вывод, ДА
}else cout << "NO!" << endl; // иначе, НЕТ
system("pause");
return 0;
}