vladun99
Программа написана неверно, имеется множество ошибок, исправьте, пожалуйста
elenaklon
Извините, но что конкретно является ошибкой в моей программе?
vladun99
Вы написали, что i mod 5 = 0, затем программа должна записать число "i", подставлю 10, вместо "i", получается 10 mod 5 = 0, то write (10), и таким образом до 40, у вас получается, что кол-во чисел от 10 до 40, это само число "i", и в ответе получается: 10,15,20,25,30,35,40
elenaklon
Вопрос звучит: "Составить программу: 1)вычисление натуральных чисел кратных 5, от 10 до 40". Где здесь слово кол-во?
vladun99
Извините, пожалуйста, тут и вправду надо было найти сами числа, а не их количество, я не сразу это понял, прощу прощения
vladun99
Program N_1; var a,b:integer; begin b:=0; begin for a:=10 to 40 do if a mod 5 = 0 then b:=b+1; end; writeln('Количество чисел, кратных 5 -', b) end.
Программа использует "a" , как счетчик от 10 до 40, а "b" , как количество чисел, если число делится на пять без остатка, то количество чисел +1, Ответ программы: 7 чисел
Answers & Comments
var i:integer;
begin
for i:=10 to 40 do
if i mod 5 = 0 then write(i,' ')
end.
var a,b:integer;
begin
b:=0;
begin
for a:=10 to 40 do
if a mod 5 = 0 then
b:=b+1;
end;
writeln('Количество чисел, кратных 5 -', b)
end.
Программа использует "a" , как счетчик от 10 до 40, а "b" , как количество чисел, если число делится на пять без остатка, то количество чисел +1,
Ответ программы: 7 чисел