Составить программу и блок-схему для решения задачи. Решение каждой задачи сопроводить пояснительной запиской с описанием используемых в задаче конструкций языка Си.
A[N] Найти среднее геометрическое элементов массива А . Ai > 0; N=10
Answers & Comments
duplerlvl85
#include <iostream> #include <cmath> using namespace std;
void main() { int n; float x=1,y,k=0; cin >> n; int *mass = new int[n]; for (int i = 0;i < n;++i) { cin >> mass[i]; } for (int i = 0;i < n;++i) { x *= mass[i]; k++; } y = pow(x, 1/k); cout << " y= " <<y; system("pause"); }
Answers & Comments
#include <cmath>
using namespace std;
void main()
{
int n;
float x=1,y,k=0;
cin >> n;
int *mass = new int[n];
for (int i = 0;i < n;++i)
{
cin >> mass[i];
}
for (int i = 0;i < n;++i)
{
x *= mass[i];
k++;
}
y = pow(x, 1/k);
cout << " y= " <<y;
system("pause");
}