Составить программу, которая меняет два введённых слова местами, и при необходимости вставляет между ними запятую
Answers & Comments
Цarь2016
Составить программу, которая меняет местами значения переменных a и b, введенных с клавиатуры, без использования дополнительных переменных вот прога которую я нашёл в инете и разбирал не понимаю одного как она вычисляет по формулам begin a:=a+b; b:=a-b; a:=a-b; end; объясните плиз если например a= 23, b=45 PascalВыделить код 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 var a,b:real; procedure change(var a,b:real); begin a:=a+b; b:=a-b; a:=a-b; end; begin writeln(' Г*,ГЎ'); readln(a,b); writeln('a=',a); writeln ('b=',b); change(a,b); writeln('a=',a); writeln ('b=',b); readln; end.
0 votes Thanks 0
kan7607
спасибо,конечно)но всё оказалось намного проще
Answers & Comments