составить программу ,которая заменяет все числа,не краатные 17 на 22 (количество элементов:М)
Answers & Comments
Ленгит
Program mass; uses crt; var x:array [1..100] of integer; i,j,m:integer;begin clrscr; write('Количество элементов: '); readln (m); for i:=1 to m do begin write('Введите ' ,i, ' элемент:'); readln(x[i]); end; for i:=1 to m do begin write (' ',x[i]:3); writeln; end; for i:=1 to m do begin if (x[i] mod 17 <> 0) then x[i]:= 22;end; writeln; for i:=1 to m do begin write (' ',x[i]:3); writeln; end; readln; end.
Answers & Comments
uses crt;
var
x:array [1..100] of integer;
i,j,m:integer;begin
clrscr;
write('Количество элементов: ');
readln (m);
for i:=1 to m do
begin
write('Введите ' ,i, ' элемент:');
readln(x[i]);
end;
for i:=1 to m do
begin
write (' ',x[i]:3);
writeln;
end;
for i:=1 to m do
begin
if (x[i] mod 17 <> 0) then
x[i]:= 22;end;
writeln;
for i:=1 to m do
begin
write (' ',x[i]:3);
writeln;
end;
readln;
end.