Составить программу на Паскале с помощью цикла с неизвестным числом повторений. "На первый же день появления красавца Васи в колледже в него влюблялись 2 девочки. С каждым днем их число увеличивалось в два раза, но каждую неделю 23 девочки разочаровывались в нем и влюблялись в Сережу. Через сколько дней в Васю влюбятся 45 девочек?"
Answers & Comments
Verified answer
Var k,n:integer;begin
n:=1;
k:=2;
while k<=45 do
begin
n:=n+1;
k:=k*2;
if n mod 7 = 0 then k:=k-23;
end;
writeln('n = ',n,' k = ',k);
end.
Результат:
n = 6 k = 64