СОСТАВИТЬ ПРОГРАММУ НА ЯЗЫКЕ ПАСКАЛЬ
Помогите, срочно нужна помощь
Составить программу. Из 800 учащихся школы на данный момент посещают школу N человек. Определить, через сколько дней число посещающих школу составит менее половины учащихся школы, если число не больных школьников каждый день уменьшается на 10% от предыдущего дня.
Answers & Comments
var n,k:integer;
begin
repeat
write('Введите количество не больных школьников от 401 до 800 n=');
readln(n);
until(n>400)and(n<=800);
k:=0;
while n>400 do
begin
n:=round(n*0.9);
k:=k+1;
end;
write('Через ',k,' дн. ',' количество учащихся составит менее половины = ',n);
end.
взял отсюда: https://studassistent.ru/pascal-abc/opredelit-cherez-skolko-dnej-chislo-poseshhayushhikh-shkolu-sostavit-menee-poloviny-uchashhikhsya-shkoly-pascal-abc