Составить программу возведения заданного натурального числа в третью степень, используя следующую закономерность: 1 3 = 1, 2 3 = 3 + 5, 3 3 = 7 + 9 + 11, 4 3 = 13 + 15 + 17 + 19, 5 3 = 21 + 23 + 25 + 27 + 29. Помогите написать программу в С++. ДАМ МНОГО БАЛЛОВ!!!
Answers & Comments
#include<bits/stdc++.h>
using namespace std;
int main()
{int n;
cin>>n;
int a[n+2];
a[1]=n*n-n+1;
for (int i=2;i<=n;i++)
a[i]=a[i-1]+2;
cout<<n<<"^3 = ";
for (int i=1;i<=n;i++)
{cout<<a[i];
if (i<n+1)
cout<<" + ";
}
}
##я понял твою последовательность я понял формулу через
## n. если ты заметишь в каждой последовательности N членов : для ## одного двух трех и т.д. a1=n^2-n+1 через арифметическую последовательность a1 an=a1+2(n-1); их сумма же равна n*n*n мы находим аналогично все члены прогрессии