составить программу вычеслений степени числа А с натуральным показателем N. С объяснением ладно .Pascal
Например, вот так:
var z:real; a,n:integer;beginread(a,n); z:=exp(n*ln(a));writeln('z = ',z);readln;end.
exp(n*ln(a)) - "формула" возведения в степень в паскале (одна из множества возможных), где n и а - произвольные, z не может быть integer
Copyright © 2024 SCHOLAR.TIPS - All rights reserved.
Answers & Comments
Например, вот так:
var z:real; a,n:integer;
begin
read(a,n);
z:=exp(n*ln(a));
writeln('z = ',z);readln;
end.
exp(n*ln(a)) - "формула" возведения в степень в паскале (одна из множества возможных), где n и а - произвольные, z не может быть integer