составить программу вычисления суммы чётных чисел и произведение нечётных чисел от 1 до 10.
var i, s, pr: integer;
begin
s:=0;
pr:=1;
for i:=1 to 10 do
if i mod 2=1 then pr:=pr*i;
if i mod 2=0 then s:=s+i;
end;
writeln('Произведение нечетных чисел: ',pr, ', сумма четных чисел: ', s);
end.
А вообще это элементарное задание. Неужели вам не объясняли, как такие делать?
Copyright © 2024 SCHOLAR.TIPS - All rights reserved.
Answers & Comments
var i, s, pr: integer;
begin
s:=0;
pr:=1;
for i:=1 to 10 do
begin
if i mod 2=1 then pr:=pr*i;
if i mod 2=0 then s:=s+i;
end;
writeln('Произведение нечетных чисел: ',pr, ', сумма четных чисел: ', s);
end.
А вообще это элементарное задание. Неужели вам не объясняли, как такие делать?