Составить программы для решения задач на языке паскаль ABC:
1)Определить, является ли целое число N кратным числу 5.
2)Определить, является ли число C средним арифметическим чисел A и B (A, B, C - вводятся с клавиатуры).
3)Компьютер спрашивает: "Сколько вам лет?". Если ответ меньше 14, то отвечает "Вам еще рано получать паспорт". Если ответ больше или равен 14 отвечает "Поздравляю! Вы гражданин России!".
4)Составить программу, которая запрашивает ввод температуры тела человека и определяет, здоров он или болен (здоров при 36 < t < 37)
Answers & Comments
n:longint;
begin
readln(n);
if n mod 5=0 then writeln('Число N является кратным чилслу 5')else
writeln('Чило N не является кратным числу 5' );
end.
2)
var
a,b,c:longint:
begin
readln(a,b,c);
if (a+b)div 2=c then writeln('Число C является средним арефметическим чисел A и B') else writeln(' Число C является средним арефметическим чисел A и B') else writeln('Число C не является средним арефметическим чисел A и B ');
end.
3)
var
a:longint;
begin
write('Сколько вам лет?');
readln(a);
if a<14 then write('Вам еще рано получать паспорт?') else write('Поздравляю! Вы гражданин России!');
end.
4)
var
a:extended;
begin
readln(a);
if (a>36)and(a<37) then writeln('Вы здоровы') else writeln('Вы больны');
end.