Home
О нас
Products
Services
Регистрация
Войти
Поиск
Dmitriy4737
@Dmitriy4737
July 2022
1
11
Report
Составьте программу формирования массива в Pascal Срочно!!!
1 2 3 4 n 0
2 3 4 n 0 0
3 4 n 0 0 0
4 n 0 0 0 0
n 0 0 0 0 0
Please enter comments
Please enter your name.
Please enter the correct email address.
Agree to
terms of service
You must agree before submitting.
Send
Answers & Comments
petyaGavrikov
Verified answer
Const n=5;
var a:array[1..n,1..n+1] of integer;
i,j:integer;
begin
for i:=1 to n do
begin
for j:=1 to n-i+1 do a[i,j]:=j+i-1;
for j:=n-i+2 to n+1 do a[i,j]:=0;
end;
for i:=1 to n do
begin
for j:=1 to n+1 do write(a[i,j]:2);
writeln;
end;
end.
Результат:
1 2 3 4 5 0
2 3 4 5 0 0
3 4 5 0 0 0
4 5 0 0 0 0
5 0 0 0 0 0
2 votes
Thanks 1
Dmitriy4737
Спасибо!
petyaGavrikov
Пожалуйста.
More Questions From This User
See All
Dmitriy4737
August 2022 | 0 Ответы
Даю 80 баллов за 2 задания по биологии. Но нужно решить правильно!Сами задания:З...
Answer
Dmitriy4737
June 2022 | 0 Ответы
Создать массив из N векторов (Vector3). Значения (x, y, z) рандомятся в отрезке ...
Answer
рекомендуемые вопросы
rarrrrrrrr
August 2022 | 0 Ответы
о чем должны позаботиться в первую очередь взрослые при организационном вывозе н...
danilarsentev
August 2022 | 0 Ответы
Есть два станка на которых выпускают одинаковые запчасти один производит a запча...
myachina8
August 2022 | 0 Ответы
Найти по графику отношение V3:V1. В ответах написано 9, но нужно решение...
ydpmn7cn6w
August 2022 | 0 Ответы
Choose the correct preposition: 1.I am fond (out,of,from) literature. 2.where ar...
millermilena658
August 2022 | 0 Ответы
Определите Как создавалась и кто создавал арабское государство в крации...
MrZooM222
August 2022 | 0 Ответы
Ч. Айтманов в рассказе "Красное яблоко" использует метод рассказ в рассказе. Опи...
timobila47
August 2022 | 0 Ответы
каково было назначение каждой из частей византийского храма? помогите пожалуйста...
ivanyyaremkiv
August 2022 | 0 Ответы
moment. 6....
Участник Знаний
August 2022 | 0 Ответы
Пожалуйста!!!!!!!!!!!!...
sarvinozwakirjanova
August 2022 | 0 Ответы
помогите пожалусто пж...
×
Report "Составьте программу формирования массива в Pascal Срочно!!! 1 2 3 4 n 0 2 3 4 n ..."
Your name
Email
Reason
-Select Reason-
Pornographic
Defamatory
Illegal/Unlawful
Spam
Other Terms Of Service Violation
File a copyright complaint
Description
Helpful Links
О нас
Политика конфиденциальности
Правила и условия
Copyright
Контакты
Helpful Social
Get monthly updates
Submit
Copyright © 2025 SCHOLAR.TIPS - All rights reserved.
Answers & Comments
Verified answer
Const n=5;var a:array[1..n,1..n+1] of integer;
i,j:integer;
begin
for i:=1 to n do
begin
for j:=1 to n-i+1 do a[i,j]:=j+i-1;
for j:=n-i+2 to n+1 do a[i,j]:=0;
end;
for i:=1 to n do
begin
for j:=1 to n+1 do write(a[i,j]:2);
writeln;
end;
end.
Результат:
1 2 3 4 5 0
2 3 4 5 0 0
3 4 5 0 0 0
4 5 0 0 0 0
5 0 0 0 0 0