Составьте программу к следующей задаче:
Ученик начал решать задачи данного урока программирования, когда электронные часы показывали h1 часов и min1 минут, а закончил, когда было h2часов и min2 минут. Составьте программу, позволяющую определить, сколько времени (в часах и минутах) ученик решал эти задачи.
Answers & Comments
Verified answer
#include <iostream>using namespace std;
int main() {
int h1,min1,h2,min2,h,min,m;
cin >> h1 >> min1;
cin >> h2 >> min2;
m = (h2*60+min2)-(h1*60+min1);
h = m / 60;
min = m % 60;
cout << "h = " << h << " min = " << min;
return 0;
}
Пример:
1 55
3 15
h = 1 min = 20