составьте программу которая осуществляет ввод в массив с клавиатуры 7 целых чисел и заменяет кратные 4 числа на 1
Answers & Comments
WhitePineapple
Var a:array[1..7] of integer; i:integer; n1:real; begin writeln('Введите 7 целых чисел'); for i:=1 to 7 do begin repeat read(n1); if (n1<>round(n1)) then writeln('Необходимо целое число'); until (n1=round(n1)); a[i]:=round(n1); end; for i:=1 to 7 do begin if (a[i] mod 4=0) then a[i]:=1; end; writeln('Полученный массив:'); for i:=1 to 7 do write(a[i]:5); writeln(''); end.
Answers & Comments
begin
writeln('Введите 7 целых чисел');
for i:=1 to 7 do
begin
repeat
read(n1);
if (n1<>round(n1)) then writeln('Необходимо целое число');
until (n1=round(n1));
a[i]:=round(n1);
end;
for i:=1 to 7 do
begin
if (a[i] mod 4=0) then a[i]:=1;
end;
writeln('Полученный массив:');
for i:=1 to 7 do
write(a[i]:5);
writeln('');
end.