составьте программу которая заполняет массив а[1..10] заполните случайными целыми числами в диапазоне от 0 до 2 и выводит количество элементов,равных 1.
Answers & Comments
A1darVAR a:array[1..10] of integer; i,s:integer; BEGIN s:=0; for i:=1 to 10 do begin a[i]:=random(3); if a[i]=1 then s:=s+1 end; writeln ('Массив a: '); for i:=1 to 10 do write (a[i],' '); writeln; writeln ('Элементов массива, равных одному: ',s) END.
Answers & Comments
i,s:integer;
BEGIN
s:=0;
for i:=1 to 10 do
begin
a[i]:=random(3);
if a[i]=1 then s:=s+1
end;
writeln ('Массив a: ');
for i:=1 to 10 do write (a[i],' ');
writeln;
writeln ('Элементов массива, равных одному: ',s)
END.