Составьте программу, которая запрашивает стоимость 1 кг конфет и
выводит на экран стоимость 0.1, 0.2, 0.3, ..., 1 кг конфет. Результат работы
программы может выглядеть так:
Введите стоимость 1 кг конфет: 7.6
Стоимость 0.1 кг конфет = 0.76 руб.
Стоимость 0.2 кг конфет = 1.52 руб.
Стоимость 0.3 кг конфет = 2.28 руб.
Язык программирования- Pascal ABC
Answers & Comments
Program candies;
var
i:integer;
c,d,m: real;
begin
write('Введите стоимость 1 кг конфет:');
readln(c);
d:=0.1;
for i:=1 to 10 do
begin
m := d*c;
writeln('Стоимость ',d,' кг конфет = ', m);
d:= d+0.1;
end;
end.