November 2021 0 4 Report
Составьте программу, определяющую, лежит ли точка с указанными координатами X, Y на окружности радиуса R с центром в
начале координат.

 


Program Frankenstein;


var


x,y,r:integer;


Begin


Write('Введите координату X: ');


Readln(x);


Write('Введите координату Y: ');


Readln(y);


Write('Введите длину радиуса R: ');


Readln(r);


If (sqr(x)+sqr(y))=r
then writeln('Точка лежит на
окружности!')


Else writeln('Точка не лежит на
окружности!');




End.

 

Почему программа всегда показывает что точка не лежит на окружности, хотя на самом деле она лежит! Где я ошибся?
Please enter comments
Please enter your name.
Please enter the correct email address.
You must agree before submitting.

Copyright © 2024 SCHOLAR.TIPS - All rights reserved.