Составьте программу в Pascal ABC используя простые команды(9 класс). Вводится существительное первого склонения в единственном числе (имена существительные женского, мужского рода, имеющие в именительном падеже единственного числа окончание -а (-я)). Программа должна выводить это существительное во множественном числе. Пример: страна страны; земля ---- земли. 30 баллов.
Answers & Comments
Ответ:
program zadanie4b;
var su:string;
begin
write('Введите существительное первого склонения в единственном числе:');readln(su);
if su[length(su)]='а' then
writeln(copy(su,1,length(su)-1)+'ы') else
if su[length(su)]='я' then
writeln(copy(su,1,length(su)-1)+'и')
end.
Объяснение: