составьте программу, заменяющую меньшее из двух данных чисел на среднее арифметическое этих чисел,а большее из двух данных чисел на среднюю геометрическую этих чисел help me!!!please
program lkcfndsl;
uses crt;
var a,b,s,g:real;
begin
clrscr;
readln(a,b);
s:=(a+b)/2;
g:=sqrt(a*b);
if a>b then a:=g else a:=s;
if b>a then b:=g else b:=s;
writeln(a,b);
readln;
end.
Надеюсь так понял.
Copyright © 2025 SCHOLAR.TIPS - All rights reserved.
Answers & Comments
program lkcfndsl;
uses crt;
var a,b,s,g:real;
begin
clrscr;
readln(a,b);
s:=(a+b)/2;
g:=sqrt(a*b);
if a>b then a:=g else a:=s;
if b>a then b:=g else b:=s;
writeln(a,b);
readln;
end.
Надеюсь так понял.