написать программу нахождения суммы и произведения цифр трехзначного числа
Написать программу нахождения площади поверхности куба
Написать программу нахождения площади прямоугольника
Answers & Comments
adriannakoltzova
Сумма,произведение и по отдельности единицы, десятки и сотни program A1; Var a, d, b, c,r,t:Integer; begin Write(' введите трех значное число ' ) ;Read(a); d:=a div 100; c:=a mod 100; c:=c div 10; b:=a mod 100; b:=b mod 10; t:=d+c+b; r:=d*c*b; WriteLn(' число единиц = ', b); WriteLn(' число десятков = ', c); WriteLn(' число сотый = ', d); WriteLn(' сумма его цифр = ', t); WriteLn(' произведение его цифр = ', r);
end.
Площадь и периметр program f33; Var a, b, P, S:Real; begin Write('а = '); Read(a); Write('b = ') ;Read(b); S:=a*b; P:=(a+b)*2; WriteLn('S = ', S); WriteLn('P = ', P); end.
Answers & Comments
program A1;
Var a, d, b, c,r,t:Integer;
begin
Write(' введите трех значное число ' ) ;Read(a);
d:=a div 100;
c:=a mod 100;
c:=c div 10;
b:=a mod 100;
b:=b mod 10;
t:=d+c+b;
r:=d*c*b;
WriteLn(' число единиц = ', b);
WriteLn(' число десятков = ', c);
WriteLn(' число сотый = ', d);
WriteLn(' сумма его цифр = ', t);
WriteLn(' произведение его цифр = ', r);
end.
Площадь и периметр
program f33;
Var a, b, P, S:Real;
begin
Write('а = '); Read(a);
Write('b = ') ;Read(b);
S:=a*b;
P:=(a+b)*2;
WriteLn('S = ', S);
WriteLn('P = ', P);
end.