СРОЧНО!!! Написать программу в С++!
Дано предложение. Определить долю (в %) буква «ь» в нём. Нужно решить не используя класс, а найти количество букв в данном предложении, найти длину предложения, найти отношение количества данных букв всему предложению умножить на 100.
Answers & Comments
Ответ:
#include <iostream>
#include <string>
#include <Windows.h>
int main()
{
// Обеспечение нормальной работы программы с кириллицей
SetConsoleCP(1251);
SetConsoleOutputCP(1251);
std::string s;
int i = 0, cnt = 0, length = 0;
std::cout << "Введите предложение: ";
getline(std::cin, s);
while (s[i++] != '\0')
length++;
for (i = 0; i < length; i++)
if (s[i] == 'ь') cnt++;
std::cout << "Доля букв 'ь' в предложении: " << (cnt*1.0/length)*100 << "%" << std::endl;
return 0;
}