Срочно!!!!!!!!!!!!!!!!!!!!! напишите программу в паскаль которая выводит квадраты первых 7 нечетных чисел в массиве
Answers & Comments
Alex24241
Не знаю как именно нужно было заполнять массив, поэтому сделал рандом Var a:array[1..20] of Integer ; n,i:integer; Begin n:=7; WriteLn('Массив'); For i:= 1 to 20 do begin a[i]:=Random(20); Write(a[i]:3); end; Writeln; Writeln('Квадраты первых 7 нечетных чисел'); For i:=1 to 20 do if (a[i] mod 2 = 1) and (n<>0)then begin Write(sqr(a[i]):4); n:=n-1; end; end.
Answers & Comments
Var a:array[1..20] of Integer ;
n,i:integer;
Begin
n:=7;
WriteLn('Массив');
For i:= 1 to 20 do
begin
a[i]:=Random(20);
Write(a[i]:3);
end;
Writeln;
Writeln('Квадраты первых 7 нечетных чисел');
For i:=1 to 20 do
if (a[i] mod 2 = 1) and (n<>0)then
begin
Write(sqr(a[i]):4);
n:=n-1;
end;
end.