Срочно очень Прошу. Написать программу в Паскале: Надо заполнить массив случайными числами в диапазоне от 25 до 50, найти сумму четных чисел и их количество.
Begin var a := arrrandom(readinteger('Введите размер массива:'), 25, 50).println; writeln('Кол-во четных чисел:', a.where(x -> x mod 2 = 0).count); writeln('Сумма четных чисел:', a.where(x -> x mod 2 = 0).sum); end.
1 votes Thanks 0
contrlc
"Слишком поздно, чтобы изменить ответ СОХРАНИТЬ ОТВЕТ" <- :(
contrlc
begin var a := arrrandom(readinteger('Введите размер массива:'), 25, 50).println; writeln('Кол-во четных чисел:', a.where(x -> x mod 2 = 0).count); writeln('Сумма четных чисел:', a.where(x -> x mod 2 = 0).sum); end.
Answers & Comments
Verified answer
Beginvar a := arrrandom(readinteger('Введите размер массива:'), 25, 50).println;
writeln('Кол-во четных чисел:', a.where(x -> x mod 2 = 0).count);
writeln('Сумма четных чисел:', a.where(x -> x mod 2 = 0).sum);
end.
СОХРАНИТЬ ОТВЕТ" <- :(
var a := arrrandom(readinteger('Введите размер массива:'), 25, 50).println;
writeln('Кол-во четных чисел:', a.where(x -> x mod 2 = 0).count);
writeln('Сумма четных чисел:', a.where(x -> x mod 2 = 0).sum);
end.