СРОЧНО ПАСКАЛЬ
Даны значения двух моментов времени, принадлежащих одним и тем же суткам: часы, потом минуты и секунды для каждого из моментов времени. Известно, что второй момент времени наступил не раньше первого. Определите, сколько секунд прошло между двумя моментами времени. Входные данные В первой строке входных данных находятся три целых числа — часы, минуты и секунды первого момента времени. Во второй строке — три числа, характеризующие второй момент времени. Число часов лежит в диапазоне от 0 до 23, число минут и секунд — от 0 до 59. Выходные данные Выведите число секунд между двумя моментами времени.
Answers & Comments
PascalABC
Program Time;
var h1,h2,m1,m2,s1,s2:integer;
begin
writeln('Введите первый момент времени:');
write('Часы = '); readln(h1);
write('Минуты = '); readln(m1);
write('Секунды = '); readln(s1);
writeln('Введите второй момент времени:');
write('Часы = '); readln(h2);
write('Минуты = '); readln(m2);
write('Секунды = '); readln(s2);
s1:=h1*3600+m1*60+s1;
s2:=h2*3600+m2*60+s2;
writeln('Между первым и вторым моментом прошло ',s2-s1,' секунд.');
end.