Срочно программа на паскале. 50 баллов
Напишите программу, которая в последовательности натуральных чисел
определяет сумму трёхзначных чисел, начинающихся на 4. Программа
получает на вход количество чисел в последовательности, а затем сами числа.
В последовательности всегда имеется трёхзначное число, начинающееся на 4.
Количество чисел не превышает 200. Введённые числа по модулю не
превышают 10000.
Программа должна вывести одно число: сумму трёхзначных чисел,
начинающихся на 4.
Answers & Comments
Verified answer
var n,i,a,s:integer;
begin
write('n = ');
readln(n);
s:=0;
writeln('Введите ',n,' натуральных чисел');
for i:=1 to n do
begin
read(a);
if a div 100=4 then s:=s+a;
end;
writeln('s = ',s);
end.
Пример
n = 5
Введите 5 натуральных чисел
123 456 4321 45 401
s = 857