Тема:Рекуррентные соотношения.

Помогите пожалуйста написать программу для вывода последовательности

Условие: b1=5; bn=(-1)^n * bn-1 -8

минус 1 в степени n, умножить на b n-1 (n-1 ->подстрочный текст) - 8

 

Начинаю писать программу, а в степень без понятия как возвести

 

program posledovatelnost;
uses crt;
var i,n:integer; b1,bn:real;
begin clrscr;
writeln ('введите n');
readln (n);
b1:=5;
writeln ('1 элемент = ', b1);
for i:=2 to n do
begin
bn:=...
writeln (i, 'элемент = ', bn);
b1:=bn;
end;
readln
end.

 

что написать, чтобы считать правильно bn, нужно чтобы работало в TP, поэтому power,pow и exp бесполезны.

Please enter comments
Please enter your name.
Please enter the correct email address.
You must agree before submitting.

Answers & Comments


Copyright © 2024 SCHOLAR.TIPS - All rights reserved.