Требовалось написать программу при выполнении которой с клавиатуры считывается натуральное число N, не превосходящее 10^9 и выводится максимальная цифра этого числа.
var N: longint;
digit, maxdigit: integer;
begin
readln(N);
maxdigit := 10;
while N > 10 do
begin
digit := N mod 10;
if digit > maxdigit then
maxdigit := digit;
N := N div 10;
end;
writeln(digit);
end.
Последовательно выполните следующее.
1. Напишите что выведет это программа при вводе числа 321.
2. Найдите все ошибки в этой программе (их может быть одна или несколько). Для каждой ошибки:
1) выпишите строку, в которой сделана ошибка;
2) укажите, как исправить ошибку, - приведите правильный вариант строки.
Please enter comments
Please enter your name.
Please enter the correct email address.
You must agree before submitting.

Answers & Comments


рекомендуемые вопросы

Copyright © 2025 SCHOLAR.TIPS - All rights reserved.