Требовалось написать программу вычисления факториала числа n (факториал числа n есть произведение всех целых чисел от 1 до n). Программист торопился и написал программу неправильно. Ниже приведён фрагмент его программы, в котором содержится пять ошибок:
к := 1;
f := 0;
while k f:=f * k;
к:=к + 1
Найдите ошибки. Допишите необходимые операторы и выполните программу на компьютере.
Пример входных данных
Пример входных данных Пример выходных данных
Введите n> 5 5!=120
Введите n> 6 6!=720
Answers & Comments
Verified answer
Var n,k,f:integer;begin
write('n='); readln(n);
k:=1;
f:=1;
while k<=n do
begin f:=f*k; k:=k+1; end;
writeln(n,'!=',f);
end.