Требуется разработать программу, которая получает с клавиатуры координаты точки на плоскости, и определяет, попадает ли точка в залитую оранжевым область (линии в область не входят).
Написать программу нужно двумя способами (можно в одной программе ввести данные, а потом двумя способами получить результат):
1) С применением логических операций
2) С помощью вложенных условных операторов.
Разрешается также применение математических функций, арифметических операций.
Ответ - текст программы в документе MS Word.
Answers & Comments
Ответ:
Могу подсказать только 1 вариант:
Объяснение:
Module Module1
Sub Main()
Dim x As Single
Dim y As Single
Console.WriteLine("Введите координаты точки x ")
x = Console.ReadLine()
Console.WriteLine("Введите координаты точки y ")
y = Console.ReadLine()
If (x <= 4 And y <= 4 And y >= 4 - x) Or (y <= -4 - x And y >= -4 And x >= -4) Then Console.WriteLine("Точка принадлежит области") Else Console.WriteLine("Точка не принадлежит области")
Console.ReadKey()
End Sub
End Module