"В классе 20 учеников писали диктант по русскому языку. Напишите программу, подсчитывающую количество двоек, троек, четверок, пятерок, полученных за диктант. Посчитать средний балл за диктант с точностью до сотых." написать программу в Паскаль
begin var a:=ArrRandom(20,2,5); a.Println; For var i:=2 to 5 do Println('Кол-во',i,'=',a.Where(t->t=i).Count); Writeln('Средний бал равен ', a.Average:0:2); end.
Answers & Comments
//Версия 3.3, сборка 1611 (06.01.2018)
begin
var a:=ArrRandom(20,2,5); a.Println;
For var i:=2 to 5 do Println('Кол-во',i,'=',a.Where(t->t=i).Count);
Writeln('Средний бал равен ', a.Average:0:2);
end.
Пример:
5 3 5 2 4 3 5 5 5 3 2 2 4 4 2 3 4 3 5 4
Кол-во 2 = 4
Кол-во 3 = 5
Кол-во 4 = 5
Кол-во 5 = 6
Средний бал равен 3.65