Home
О нас
Products
Services
Регистрация
Войти
Поиск
le2002menchik
@le2002menchik
July 2022
1
19
Report
Введите размер массива N и заполните массив из N элементов числа Фибоначчи равны 1, а каждое следующее число равно сумме двух предыдущих.
Помогите пожалуйста составить программу..
Please enter comments
Please enter your name.
Please enter the correct email address.
Agree to
terms of service
You must agree before submitting.
Send
Answers & Comments
petyaGavrikov
Verified answer
Var n:integer;
a:array of integer;
begin
write('n = ');
readln(n);
SetLength(a,n);
a[0]:=1; a[1]:=1;
for var i:=2 to n-1 do a[i]:=a[i-2]+a[i-1];
for var i:=0 to n-1 do write(a[i],' ');
writeln;
end.
Пример:
n = 10
1 1 2 3 5 8 13 21 34 55
1 votes
Thanks 0
le2002menchik
спасибо большое))
petyaGavrikov
Пожалуйста.
рекомендуемые вопросы
rarrrrrrrr
August 2022 | 0 Ответы
o chem dolzhny pozabotitsya v pervuyu ochered vzroslye pri organizacionnom vyvoze n
danilarsentev
August 2022 | 0 Ответы
est dva stanka na kotoryh vypuskayut odinakovye zapchasti odin proizvodit a zapcha
myachina8
August 2022 | 0 Ответы
najti po grafiku otnoshenie v3v1 v otvetah napisano 9 no nuzhno reshenie
ydpmn7cn6w
August 2022 | 0 Ответы
Choose the correct preposition: 1.I am fond (out,of,from) literature. 2.where ar...
millermilena658
August 2022 | 0 Ответы
opredelite kak sozdavalas i kto sozdaval arabskoe gosudarstvo v kracii
MrZooM222
August 2022 | 0 Ответы
ch ajtmanov v rasskaze krasnoe yabloko ispolzuet metod rasskaz v rasskaze opi
timobila47
August 2022 | 0 Ответы
kakovo bylo naznachenie kazhdoj iz chastej vizantijskogo hrama pomogite pozhalujsta
ivanyyaremkiv
August 2022 | 0 Ответы
moment. 6....
pozhalujsta8b98a56c0152a07b8f4cbcd89aa2f01e 97513
sarvinozwakirjanova
August 2022 | 0 Ответы
pomogite pozhalusto pzha519d7eb8246a08ab0df06cc59e9dedb 6631
×
Report "Введите размер массива N и заполните массив из N элементов числа Фибоначчи равны..."
Your name
Email
Reason
-Select Reason-
Pornographic
Defamatory
Illegal/Unlawful
Spam
Other Terms Of Service Violation
File a copyright complaint
Description
Helpful Links
О нас
Политика конфиденциальности
Правила и условия
Copyright
Контакты
Helpful Social
Get monthly updates
Submit
Copyright © 2024 SCHOLAR.TIPS - All rights reserved.
Answers & Comments
Verified answer
Var n:integer;a:array of integer;
begin
write('n = ');
readln(n);
SetLength(a,n);
a[0]:=1; a[1]:=1;
for var i:=2 to n-1 do a[i]:=a[i-2]+a[i-1];
for var i:=0 to n-1 do write(a[i],' ');
writeln;
end.
Пример:
n = 10
1 1 2 3 5 8 13 21 34 55