danilcapitan
program Primer_1; var f:text; x,k: integer; begin assign(F,'primer1.dat'); {связываем с внешним файлом} reset(F); {открываем для чтения} while not eof(f) do {пока не конец файла} begin k:=0; {начальное количество элементов строки} while not eoln(f)do {пока не конец строки} begin read(f,x); {считываем очередное число} write(x,' '); {выводим его на экран} inc(k); {увеличиваем счетчик} end; writeln('в строке ',k,' элементов'); readln(f); {переходим к следующей строке файла} end; close(f); end.
Answers & Comments
Ответ:
Program chisla;
var a:longint;
Begin
assign(input,'input.txt');
reset(input);
read(a);
close(input);
assign (output,'output.txt');
rewrite(output);
writeln(a);
close(output);
End.
Объяснение:
Входные данные:
В единственной строке входного файла input.txt записано число.
Выходные данные:
В единственную строку выходного файла output.txt нужно вывести в точности то же число, которое задано во входном файле.
var f:text;
x,k: integer;
begin
assign(F,'primer1.dat'); {связываем с внешним файлом}
reset(F); {открываем для чтения}
while not eof(f) do {пока не конец файла}
begin
k:=0; {начальное количество элементов строки}
while not eoln(f)do {пока не конец строки}
begin
read(f,x); {считываем очередное число}
write(x,' '); {выводим его на экран}
inc(k); {увеличиваем счетчик}
end;
writeln('в строке ',k,' элементов');
readln(f); {переходим к следующей строке файла}
end;
close(f);
end.