паскаль: Написать программу для определения в двумерном массиве целых чисел D[6,6] максимальный элемент под главной диагональю. Оформить ввод/вывод массива.
Answers & Comments
SanGreen74
Var a:array [1..100, 1..100] of integer; i,j,max:longint; begin for i:=1 to 4 do for j:=1 to 4 do read(a[i,j]); max:=a[2,1]; for i:=1 to 6 do for j:=1 to 6 do if (a[i,j]>max) and (i>j) then max:=a[i,j]; for i:=1 to 6 do begin for j:=1 to 6 do write(a[i,j],' '); writeln; end; writeln('Максимальный элемент под главной диагональю - ',max); end.
Answers & Comments
i,j,max:longint;
begin
for i:=1 to 4 do
for j:=1 to 4 do read(a[i,j]);
max:=a[2,1];
for i:=1 to 6 do
for j:=1 to 6 do
if (a[i,j]>max) and (i>j) then max:=a[i,j];
for i:=1 to 6 do begin
for j:=1 to 6 do write(a[i,j],' ');
writeln;
end;
writeln('Максимальный элемент под главной диагональю - ',max);
end.