Задача на c++
Напишите программу, которая находит все различные цифры в символьной строке.
Формат входных данных
На вход программе подаётся символьная строка.
Формат выходных данных
Программа должна вывести в одной строке все различные цифры, которые встречаются в исходной строке, в порядке возрастания. Если в строке нет цифр, нужно вывести слово 'NO'.
Answers & Comments
#include <bits/stdc++.h>
using namespace std;
bool a[10];
int main()
{
string s;
cin >> s;
for (int i = 0 ; i < s.length(); ++i)
if (isdigit(s[i]))
{
int ind = s[i]-'0';
a[ind] = true;
}
bool fl = false;
for (int i = 0; i < 10; ++i)
if (a[i])
{
fl = true;
cout << i << ' ';
}
if (!fl)
cout << "NO";
}