Задача по языку программирования Pascal
n школьников делят k яблок “поровну”, то есть так, чтобы количество яблок, доставшихся любым двум школьникам, отличалось бы не более, чем на 1.
Входные данные
Программа получает на вход числа n и k.
Выходные данные
Программа должна вывести количество школьников, которым достанется яблок меньше, чем некоторым из их товарищей.
Answers & Comments
// Внимание! Если программа не работает, обновите версию!
Begin
var (n, k) := ReadInteger2('Введите n и k');
Writeln(k - (k div n) * n);
end.
begin
readln(n,k);
x:=k-n mod k;
writeln('x=',x);
end.